Link tracking issues on emails
Incident Report for PracticeHub
Resolved
Our provider has identified and fixed the issue with the link tracking service. All click.pstmrk.it links are working again. Thanks for your patience!
Posted May 15, 2018 - 10:18 UTC
Investigating
Our email service provider Postmark has notified us that they are having issues with their click tracking service which means any links clicked in PracticeHub are non functioning.

They are currently investigating this issue
Posted May 15, 2018 - 09:03 UTC
This incident affected: Web Application and Post Office.