Support response times
Incident Report for PracticeHub
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 07:59 UTC
Identified
We are currently experiencing very high support volumes. We're working hard to respond to these as quickly as possible. If you are on a free trial, responses may be delayed slightly longer.

As always you may be able to find the answer to your queries in our help centre
https://learn.practicehub.io

Thanks for your patience and understanding!
Posted Apr 06, 2020 - 09:09 UTC
This incident affected: EU Region (Neptune), AU Region (Apollo), and US Region (Vulcan).