Help centre down
Incident Report for PracticeHub
Resolved
This incident has been resolved
Posted Apr 18, 2020 - 15:27 UTC
Identified
Our help centre at https://learn.practicehub.io is currently unavailable.

The problem has been identified and a fix is in progress.
Posted Apr 18, 2020 - 14:48 UTC
This incident affected: EU Region (Neptune), AU Region (Apollo), and US Region (Vulcan).